Register with us today

and in less than 60 seconds continue your access to:Latest news headlinesAnalytical topics and featuresCommodities videos, podcast & blogsSample market prices & dataSpecial reportsSubscriber notes & daily commodity email alerts

Already have an account?

Log in to register

Forgot Password

Please Note: Platts Market Center subscribers can only reset passwords via the Platts Market Center

Enter your Email ID below and we will send you an email with your password.


  • Email Address* Please enter email address.

If you are a premium subscriber, we are unable to send you your password for security reasons. Please contact the Client Services team.

If you are a Platts Market Center subscriber, to reset your password go to the Platts Market Center to reset your password.

Platts on the Net (POTN): Update to supported Operating Systems

In order to stay in line with industry security standards, our POTN technology partner Eze Software will be disabling obsolete encryption protocols (SSLv3) and outdated ciphers (RC4 and 3DES) on external facing services.

As a result, any user that employs a legacy operating system that predates Windows 7 (e.g. Windows XP or Windows 2003) needs to upgrade to a supported operating system prior to 19 October 2019 to avoid disruption of service. For clarity, after 19 October you will no longer be able to connect to POTN using an unsupported operating system. Please visit https://www.spglobal.com/platts/en/support/software-user-manuals for a list of supported operating systems. While you are there, please consider downloading and installing the latest version of POTN (2019.3) to ensure your system is as up to date as possible.

For any questions or assistance, please contact support@platts.com.